Uber Drivers Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
263 Posts
Discussion Starter · #1 ·
Noticed today that the Android app stays on the loading screen until you have a full GPS lock. Before it didn't care if there was only partial location (i.e. non-GPS).

Note that this might be old and I only just noticed it, but I'm posting it anyway because over the past few days there's been complaints of infinite loading screen.
 

·
Registered
Joined
·
685 Posts
Perhaps they're trying to prevent people from driving from their couch. I know of a lot of drivers in slower markets that will login while at home and wait for a ping. Personally I don't see a problem with that if they're dressed and ready to roll but Uber likes us to sit in our cars for hours if necessary.
 

·
Registered
Joined
·
1,720 Posts
I always drive around with the GPS set to device only. Have had some intermittent issues with GPS set to 'high accuracy',especially downtown where signals are bouncing around on buildings.

But I've noticed the driver app starts much more quickly, often instantly, with GPS set to high accuracy. In fact, this is often the only way to start the app without seeing the loading page display forever.
 

·
Registered
Joined
·
684 Posts
I've been having a lot of problems with the infinite loading of the app in the last week. Takes forever to go online at times. But even worse is not being able to start the ride until you drive off. Also bad is not being able to complete the ride until you drive off. It is getting quite bothersome.

Are you saying this is because of GPS? Is there a way to fix it?
 

·
Registered
Joined
·
1,720 Posts
Are you saying this is because of GPS? Is there a way to fix it?
Just an observation.

On an Android, there a few settings for GPS. Either 'High Accuracy' (which uses WiFi, mobile network, & phone GPS for your location) or phone GPS only. Probably something similar on iPhones. When I try to start the app with phone GPS only, it'll show the splash screen for a long time.... Sometimes never getting off it. No issues when I have GPS set to High accuracy.
 

·
Registered
Joined
·
684 Posts
My Android device is set for high accuracy and I still get the long splash screen. Really annoying at pickup or drop off. Sometimes have to ask the pax where we are going because the app is being stupid. When I start rolling the app will usually come up within a block or two.
 

·
Registered
Joined
·
448 Posts
My Android phone automatically re-enables Wifi when I start the Uber app.

I've seen the slow start, too, but I don't think it's a GPS issue.
Restarting does not fix it. And all the other apps (including location-based
apps) are working perfectly during this time. It's just Uber.

The other bad thing I've seen lately is that the Uber app does not come up with
the Destination when you Start Trip. The screen changes and you are On Trip
but the destination just shows the pickup address. It takes 5-60 seconds after
Start Trip for the destination address to come up, so I have to sit there like
an idiot before I can go anywhere. Then I have to push the Navigate button
to start Google Maps which also takes a while (unless it's Waze, which is insant).

I think this is a server issue with Uber, not the GPS.
 

·
Premium Member
Joined
·
714 Posts
I always drive around with the GPS set to device only. But I've noticed the driver app starts much more quickly, often instantly, with GPS set to high accuracy. In fact, this is often the only way to start the app without seeing the loading page display forever.
In the past, I have traced the problem of the Uber driver app never getting past the launch animation screen to using "GPS Only" instead of "High Accuracy", but as others have mentioned here and this thread - https://uberpeople.net/threads/anyo...loading-time-takes-up-to-1-min-for-me.146980/ - the launch delay problem is happening a lot more lately.
 
1 - 9 of 9 Posts
Top